Hello & Welcome to our community. Is this your first visit? Register

Thanks Thanks:  2
Likes Likes:  3
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    Bhlim09 (OP)
    Junior Member
    Join Date
    Sep 2019
    Location
    SG
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Speedometer incorrect speed reading

    Hi all , i tried to look around for an answer to my question but couldnt , therefore i am posting this .

    I recently bought a 2008 FZ6N S2 , supposed to have ABS but previous owner had “bypassed” the system . All good except for the speedometer , which i understand the readings on the speedo are taken from the ABS sensor . While i was travelling at 100KPH (Satellite speed on phone ) , my speed only shown 58 KPH (not on MPH mode , even lesser speed if i switch to MPH ) .

    So one day , remove the front wheel sensor, went for a quick ride , the speedo started showing numbers ,but not when i removes the rear sensor with my front mounted on . So the question is , does the readings on the speedo was actually taken from both sensor or only the rear . Thanks !


    Sent from my iPhone using Tapatalk

  2. #2
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    11,370
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)

    Re: Speedometer incorrect speed reading

    I believe the speed is taken off a sensor at the back of the engine.

    It has nothing to do with ABS
    Scott
    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(no DB killers), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Grip Puppies, Yamaha rear rack with custom aluminum flat rack.

  3. #3
    Bhlim09 (OP)
    Junior Member
    Join Date
    Sep 2019
    Location
    SG
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Speedometer incorrect speed reading

    Quote Originally Posted by TownsendsFJR1300 View Post
    I believe the speed is taken off a sensor at the back of the engine.

    It has nothing to do with ABS
    That was what i thought too , but for ABS model , speed readings are taken off one/both of the ABS sensor .


    Sent from my iPhone using Tapatalk

  4. #4
    Vrrroooooom! Speedometer incorrect speed reading Motogiro's Avatar
    Join Date
    May 2008
    Location
    San Diego, Ca.
    Posts
    13,842
    Mentioned
    97 Post(s)
    Tagged
    0 Thread(s)

    Re: Speedometer incorrect speed reading

    to this great forum!

    If the speed is taken off the ABS sensor/s and the ABS has been bypassed it would be the place to start looking for the speedo error. Maybe the system sums the sensors?
    If you can't fix it by hitting it with a hammer, it's electrical!

    Clif
    SoCal Hoon

  5. #5
    Bhlim09 (OP)
    Junior Member
    Join Date
    Sep 2019
    Location
    SG
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Speedometer incorrect speed reading

    Quote Originally Posted by Motogiro View Post
    to this great forum!

    If the speed is taken off the ABS sensor/s and the ABS has been bypassed it would be the place to start looking for the speedo error. Maybe the system sums the sensors?
    That is what i thinks too , my speed do not pop when rear sensor are removed with the front sensor attached .


    Sent from my iPhone using Tapatalk

  6. Likes Motogiro liked this post
  7. #6
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    11,370
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)

    Re: Speedometer incorrect speed reading

    Part #12 is your speed sensor:

    Scott
    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(no DB killers), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Grip Puppies, Yamaha rear rack with custom aluminum flat rack.

  8. Thanks Motogiro thanked for this post
  9. #7
    Vrrroooooom! Speedometer incorrect speed reading Motogiro's Avatar
    Join Date
    May 2008
    Location
    San Diego, Ca.
    Posts
    13,842
    Mentioned
    97 Post(s)
    Tagged
    0 Thread(s)

    Re: Speedometer incorrect speed reading

    Quote Originally Posted by TownsendsFJR1300 View Post
    Part #12 is your speed sensor:

    Yes this is the speed sensor. I don't know if they did a change on the ABS bikes but if the OP's bike has this sensor as Scott has shown, this will be the first place to look.
    If you can't fix it by hitting it with a hammer, it's electrical!

    Clif
    SoCal Hoon

  10. #8
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    11,370
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)

    Re: Speedometer incorrect speed reading

    Yamaha wouldn't have changed the design/ use of the sensor for the ABS model to include how the speedometer reads.

    I'm sure the ECU takes into account the ABS signals from the sensors to activate the ABS but that shouldn't affect his speedometer.
    Scott
    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(no DB killers), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Grip Puppies, Yamaha rear rack with custom aluminum flat rack.

  11. Thanks Motogiro thanked for this post
    Likes ShoopCE, Motogiro liked this post
 

 

Similar Threads

  1. 5-7k rpm o2 sensor reading????
    By GravisMaximus in forum FZ6 Performance Mods Section
    Replies: 2
    Last Post: 09-03-2013, 05:00 PM
  2. Speedo giving incorrect reading
    By aid-90 in forum FZ6 Electrical
    Replies: 7
    Last Post: 05-14-2013, 02:58 PM
  3. Incorrect Mileage on ODO after battery replacement
    By earharc in forum Garage / Mechanical Help
    Replies: 3
    Last Post: 05-11-2011, 05:23 PM
  4. Politically Incorrect and Funny as Hell
    By Botch in forum The Bar
    Replies: 8
    Last Post: 11-24-2008, 03:21 AM
  5. A little bit of reading material.
    By jamesfz6 in forum FZ6 General Discussion
    Replies: 2
    Last Post: 03-22-2008, 09:00 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -7. The time now is 02:13 AM.
4.2.5
Image resizer by SevenSkins
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like v3.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2007 , All content is property of 600Riders.Com All Rights Reserved. The opinions and posts on this site do not neccesarily reflect those of the site owners or operators.
Yamaha FZ6 and Yamaha rights are property of Yamaha Motor Company. 600Riders.com is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha FZ6 motorcycles. Our goal is to offer a place for Yamaha FZ6 owners to discuss rides, events, mods, maintenance, purchasing, etc
vBulletin Skin By: PurevB.com