Hello & Welcome to our community. Is this your first visit? Register

Thanks Thanks:  1
Likes Likes:  5
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    SirLanceralot (OP)
    Junior Member SirLanceralot's Avatar
    Join Date
    Jun 2017
    Location
    UT
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    05 FZ6 running rough on low to moderate throttle

    Hey guys, having a minor issue with my S1 lately. Quick backstory/breakdown...

    Bought bike in June 2017 with just over 21,000 miles (22,300 on it now), ran through most maintenance i could think of (replace brake fluid, replaced coolant, checked oil, air filter, etc etc) A few weeks after purchasing it I kept having charging issues and it ended up being a faulty stator, which i replaced and was fine for about a week or 2, then i started noticing some weird engine operation at low to moderate throttle, feels almost as if the bike is bucking back and forth, albeit lightly. First thing i thought was misfiring, so i replaced the spark plugs with brand new NGK CR9EKs, which were properly gapped, also checked the air filter which was still very clean. Didn't resolve issue so I did some research and found that the TPS has had a warranty issue, so i went into DIAG mode and tested it, read 16 on closed, and went up normally to 100 at full open. I want to get the throttle bodies synced, as I think that may be contributing to the issue, but don't have a carbtune or something similar, so i'm trying to see if a local rider has one i can borrow, to avoid paying a shop/dealer to check the sync.

    The bike usually warms up fine and has normal idle, but sometimes after riding for a while and stopping at a light or stop sign the idle will drop to around 800-1000 RPM, if i turn the bike off and on then it will idle at normal 1200-1300, so I'm stumped on what else could contribute to the issue I uploaded a video of some erratic idle that i caught when I got home from my normal 45min commute, note the strange hollow "popping" sound. It doesn't seem to be a major issue as I don't notice any erratic operation when I'm riding at highway speeds, just a nuisance when riding anywhere else, haha. Any input or suggestions of what to check is greatly appreciated!

    Thanks all!

    Last edited by SirLanceralot; 07-31-2017 at 11:13 AM. Reason: typo

  2. #2
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    10,145
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    You mentioned the re-call on the TPS. Has it been changed out???

    Just because it reads 16 and 100 means nothing. You can have one read correct thru the entire range(no skipping/missing #'s)
    and it's still bad as it may act up only when warm..

    Get a hold of your dealer or better yet Momma Yamaha and find out, have your vin ready.

    That bad loping will not occur all of a sudden from a TB sync...

    Any codes popping?
    Scott

    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(open), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Garmin 590 GPS, Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Yamaha rear rack with custom aluminum flat rack.

  3. #3
    SirLanceralot (OP)
    Junior Member SirLanceralot's Avatar
    Join Date
    Jun 2017
    Location
    UT
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Quote Originally Posted by TownsendsFJR1300 View Post
    You mentioned the re-call on the TPS. Has it been changed out???

    Just because it reads 16 and 100 means nothing. You can have one read correct thru the entire range(no skipping/missing #'s)
    and it's still bad as it may act up only when warm..

    Get a hold of your dealer or better yet Momma Yamaha and find out, have your vin ready.

    That bad loping will not occur all of a sudden from a TB sync...

    Any codes popping?
    Got it, no idea if it was replaced, the previous owner was the 2nd owner, so they might not know either, I'll look into that and find that out, since if it was not replaced then that will be a free warranty replacement, and I can at least rule that out.

    No codes are coming up at all either.

  4. Likes TownsendsFJR1300 liked this post
  5. #4
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    10,145
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Scott

    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(open), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Garmin 590 GPS, Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Yamaha rear rack with custom aluminum flat rack.

  6. #5
    SirLanceralot (OP)
    Junior Member SirLanceralot's Avatar
    Join Date
    Jun 2017
    Location
    UT
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Quote Originally Posted by TownsendsFJR1300 View Post
    I saw that earlier and that's when I checked the ranges in the DIAG mode, thinking that may not be the issue since they came out within specs. I found the bulletin for the recall, and my frame wasn't stamped near the VIN for the recall, so I'm thinking it may not have been done, I'll contact my local dealer and find out for sure.

    http://www-odi.nhtsa.dot.gov/acms/cs...6V371-8156.pdf

    EDIT: Just got off the phone with a local dealer and they looked up the VIN, recall has not been completed, so I got the bike scheduled to get that replaced, will report back after complete to see if that resolves my issue.
    Last edited by SirLanceralot; 07-31-2017 at 01:29 PM. Reason: update

  7. Likes TownsendsFJR1300 liked this post
  8. #6
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    10,145
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    My old 2004 FJR had a re-call on the TPS. It never acted up, never had an issue with it but had it replaced (for free).

    I guess those couple of years, Yamaha got some Chinese TPS's.

    Most bad ones, would NOT show a malfunction in the diagnostic mode.
    Scott

    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(open), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Garmin 590 GPS, Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Yamaha rear rack with custom aluminum flat rack.

  9. #7
    Junior Member SandyN's Avatar
    Join Date
    Aug 2014
    Location
    Deneysville, South Africa
    Posts
    99
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Mine did the same a while back and I went through all the checks that you have done; the problem was resolved by replacing the battery...

    It started with the fuel pump sounding funny and a slower than normal cranking speed. If you've had charging problems it may now be the time to put in a new battery.

  10. Likes TownsendsFJR1300, Ohendo liked this post
  11. #8
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    10,145
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Plz post the results once done..
    Scott

    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(open), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Garmin 590 GPS, Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Yamaha rear rack with custom aluminum flat rack.

  12. #9
    SirLanceralot (OP)
    Junior Member SirLanceralot's Avatar
    Join Date
    Jun 2017
    Location
    UT
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    Quote Originally Posted by SandyN View Post
    Mine did the same a while back and I went through all the checks that you have done; the problem was resolved by replacing the battery...

    It started with the fuel pump sounding funny and a slower than normal cranking speed. If you've had charging problems it may now be the time to put in a new battery.
    I initially thought that was the problem i was having with my charging system before I replaced the stator, and load tested the battery which turned out normal. I'll look into the battery again if the TPS doesn't resolve the issue!

    Quote Originally Posted by TownsendsFJR1300 View Post
    Plz post the results once done..
    Will do, earliest the dealer could get me in was next wednesday, and they don't even have the part in yet anyhow. I'll update sometime next week.

  13. #10
    2007 FZ6 TownsendsFJR1300's Avatar
    Join Date
    Feb 2009
    Location
    Cape Coral, Florida, USA
    Posts
    10,145
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)

    Re: 05 FZ6 running rough on low to moderate throttle

    You can simply put a volt meter across the battery terminals.

    With the engine running, see if your charging, well into the 13 volt area is what your looking for.
    Scott

    2007 Yamaha FZ6- BD43 headlight mod, PIAA bulbs, Stebal air horn, Scorpion SS pipes-(open), Speedohealer, HEL SS brake lines, Fenda Extenda, K&P SS re-usable oil filter, custom mounted BMW style electrical outlet(L.S.), Garmin 590 GPS, Techmount GPS mount with handlebar bar risers/set backs, additional helmet lock, custom mod'ed seat(Spencers), Hyper light-rear running/brake light, custom radiator/fan protector, Techspec tank pads, Yamaha rear rack with custom aluminum flat rack.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Running rough, like on 3 cylinders
    By 2006_FZ6 in forum Garage / Mechanical Help
    Replies: 8
    Last Post: 11-20-2015, 07:40 PM
  2. sticking throttle only when running?
    By Jaymann in forum Garage / Mechanical Help
    Replies: 25
    Last Post: 09-22-2014, 08:25 PM
  3. FZ6 2004 running rough
    By MarkyB in forum Garage / Mechanical Help
    Replies: 8
    Last Post: 11-19-2012, 08:50 AM
  4. Help!! Engine running rough / spluttering :(
    By aid-90 in forum Garage / Mechanical Help
    Replies: 6
    Last Post: 10-07-2012, 02:44 PM
  5. Slight subtle knocking on decel and rough running.
    By Kaisersoze in forum Garage / Mechanical Help
    Replies: 48
    Last Post: 07-23-2011, 09:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -7. The time now is 01:40 AM.
4.2.5
Image resizer by SevenSkins
Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like v3.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 2007 , All content is property of 600Riders.Com All Rights Reserved. The opinions and posts on this site do not neccesarily reflect those of the site owners or operators.
Yamaha FZ6 and Yamaha rights are property of Yamaha Motor Company. 600Riders.com is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha FZ6 motorcycles. Our goal is to offer a place for Yamaha FZ6 owners to discuss rides, events, mods, maintenance, purchasing, etc
vBulletin Skin By: PurevB.com